The LowID Clinic -- a support thread for LowID problems

Your computer feeling a lot slower lately? That new program you installed not working? Can't convert a specific file? Looking to buy a new hard drive or dvd writer? Would like some recommendations? Firewalls, latest threats and general P2P security issues are here also.
yairs
Donator
Donator
Posts: 7
Joined: Sun Sep 07, 2008 3:41 pm

Re: The LowID Clinic -- a support thread for LowID problems

Post by yairs » Thu Apr 01, 2010 7:11 am

Thanks for the quick reply.
soporific wrote:
yairs wrote:such a great idea!

I'm using Comodo 4 FW (supposed to be configured properly) and the windows FW is switched off.
3rd party firewalls are notorious for blocking users using emule from getting a High ID ... see if you can totally disable the FW and see if that changes things. Use the port test feature of emule to check for High ID.
The connection test failed even when the Commodo is disabled. on the other hand I can sometime pass both UDP and TCP tests even when the Commodo FW is on..but it's very random, if I try again after 2 minutes, there's a good chance I'll fail..
the thing is, I don't see any FW event on the log when I run those tests, so I don't think the FW is affecting it.

I'll ask specific questions:
1. how many shared files and/or active downloads are too many?

2. If I lose connection to the server because of too many shared files and/or active downloads, am I suppose to get a specific message? (because all I get is "Lost connection to "Server name""), followed by many connection attempts and a "You have a lowid. Please review your network config and/or your settings."
then after a few hours I might get High ID again, but it's only very temporary..

3. The reason I use the Comodo FW is because the FW that comes with Win7, does't block outgoing traffic by default and if you try to change it, it gives you very limited control as for what you want to allow through your FW (for instance, installing Live MSN Messenger would be virtually impossible while the FW is on..)

yairs
Donator
Donator
Posts: 7
Joined: Sun Sep 07, 2008 3:41 pm

Re: The LowID Clinic -- a support thread for LowID problems

Post by yairs » Fri Apr 02, 2010 10:16 am

Short update - the disconnections continue even when I allow all Outbound traffic on Win7 FW.
it must be something else then.
I'm currently sharing 112 files
and downloading about 50..
(bandwidth - cables 320KB download, 32KB upload)

Too many shared files/downloads?
am I suppose to get any specific error message when that is the case?

I'm pretty happy with my KAD connection at least..maybe I should settle with KAD?
(eventually you are suppose to find all sources using KAD right?)

Alkohol
Registered user
Registered user
Posts: 735
Joined: Sun Aug 31, 2008 3:09 pm
Has thanked: 1 time
Been thanked: 10 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by Alkohol » Sat Apr 03, 2010 12:49 pm

yairs are you using an emule mod by any chance?

yairs
Donator
Donator
Posts: 7
Joined: Sun Sep 07, 2008 3:41 pm

Re: The LowID Clinic -- a support thread for LowID problems

Post by yairs » Sat Apr 03, 2010 2:53 pm

Alkohol wrote:yairs are you using an emule mod by any chance?
No I use the official emule v0.49c.
and today it seems my situation actually improved!
I've only had 2 disconnections that lasted only 1 sec each.
and I've been connected to edonkeyserver No 2 for almost 16 hours straight (high ID and all)
I think yesterday I messed up my connection by constantly attempting stuff, changing FWs, changing ports and logging in and out of emule.
When I finally gave up and left it alone it started thriving(:

so to sum things up -I'm still using Comodo, and I still have the exact same settings.
the only changes I've made were :
1. UDP/TCP ports between the 25000 and 39999.
2. define edonkeyserver No 2 as high priority and static.
3. leave emule alone(:

Peace!

soporific
Software Moderator
Software Moderator
Posts: 100
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 9 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by soporific » Tue Apr 06, 2010 8:56 am

re: yairs

I would actually uninstall the Comodo firewall and see if that fixes it. I tried for AGES to get emule to work with Comodo Internet Security, and the only way i could get it to work was completely removing the firewall component (of comodo) from the PC. I first tried leaving the firewall on the lowest setting (ie it was bypassed) but this didn't help - the fact that the firewall component was present on the PC was stopping emule. Maybe i got the config options wrong, but i did try for a good while, and i do know a thing or 2 about this issue and PCs in general :) Even disabling the firewall in comodo wasn't the easiest thing (the option is a bit hidden) which contributed to the length of time i spent trying to get it to work. This is why i suggested disabling the firewall of Comodo. But then i realized you may have simply set the firewall to the lowest setting (ie disabled) and tried this but this won't work. It needs to be totally removed -- Comodo will ask to reboot your PC so if it isn't then you haven't succeeded in disabling it ... another thing you should know is that Windows firewall is NOT re-activated after the firewall component is removed (naughty comodo!) so make sure you re-enable it if you try this.


re: EzPimpinYa

i really can't see the problem except this ... i have had some problems with routers with pre-defined port-forwarding rules in the past. The problem appears when you try to create a custom rule. It appears the rule is created but for some reason (user error or bad coding of the GUI) the ports aren't actually forwarded. The solution is to piggy back on one of the pre-defined rules. Eg, choose a pre-existing rule, see what ports it has been set to use (view rule), enable the rule, and then use those ports for emule. By hook or by crook is my philosophy :)

yairs
Donator
Donator
Posts: 7
Joined: Sun Sep 07, 2008 3:41 pm

Re: The LowID Clinic -- a support thread for LowID problems

Post by yairs » Tue Apr 06, 2010 9:50 am

soporific wrote:re: yairs

I would actually uninstall the Comodo firewall and see if that fixes it. I tried for AGES to get emule to work with Comodo Internet Security, and the only way i could get it to work was completely removing the firewall component (of comodo) from the PC. I first tried leaving the firewall on the lowest setting (ie it was bypassed) but this didn't help - the fact that the firewall component was present on the PC was stopping emule. Maybe i got the config options wrong, but i did try for a good while, and i do know a thing or 2 about this issue and PCs in general :) Even disabling the firewall in comodo wasn't the easiest thing (the option is a bit hidden) which contributed to the length of time i spent trying to get it to work. This is why i suggested disabling the firewall of Comodo. But then i realized you may have simply set the firewall to the lowest setting (ie disabled) and tried this but this won't work. It needs to be totally removed -- Comodo will ask to reboot your PC so if it isn't then you haven't succeeded in disabling it ... another thing you should know is that Windows firewall is NOT re-activated after the firewall component is removed (naughty comodo!) so make sure you re-enable it if you try this.
Hey soporific, thanks for your advice..
Indeed the Comodo didn't ask to reboot, but looking at it's eventlog it didn't show any signs of activities either..in either cases, for now, the emule works and works well!
If the problem repeats itself I'll indeed remove Comodo and try private FW 7..
Would you recommend installing a proper ipfilter manager? (in addition to the one I use on emule?)

Cheers!

soporific
Software Moderator
Software Moderator
Posts: 100
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 9 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by soporific » Wed Apr 07, 2010 12:19 am

yairs wrote:Would you recommend installing a proper ipfilter manager? (in addition to the one I use on emule?)Cheers!
It depends how close to 'trouble' you like to go ... eg, if you always like grabbing the very latest content, i would definitely install all the protection you can, thus PeerGuardian is essential to get the latest IPFilter files. If, like me, you aren't that interested in the latest movies / music, or you are still grabbing stuff from years gone past, then just the standard IP filter should be fine, but tick the option to update once a week - if your emule client doesn't have this option, switch to a mod that does. I recommend StulleMule.

yairs
Donator
Donator
Posts: 7
Joined: Sun Sep 07, 2008 3:41 pm

Re: The LowID Clinic -- a support thread for LowID problems

Post by yairs » Thu Apr 08, 2010 8:49 am

Thanks again mate!
I'll do some research on the subject(:

Cheers!

soporific wrote:
yairs wrote:Would you recommend installing a proper ipfilter manager? (in addition to the one I use on emule?)Cheers!
It depends how close to 'trouble' you like to go ... eg, if you always like grabbing the very latest content, i would definitely install all the protection you can, thus PeerGuardian is essential to get the latest IPFilter files. If, like me, you aren't that interested in the latest movies / music, or you are still grabbing stuff from years gone past, then just the standard IP filter should be fine, but tick the option to update once a week - if your emule client doesn't have this option, switch to a mod that does. I recommend StulleMule.

soporific
Software Moderator
Software Moderator
Posts: 100
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 9 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by soporific » Thu May 27, 2010 4:23 pm

I just thought of something: some modem/routers have really bad GUIs with regard to setting custom port forwarding rules. The way to check if this is the problem is to piggy back on one of their built-in rules (if it has this feature). They usually have preset rules for lots of games (eg Quake), and various networking applications (eg pcAnywhere). You just tell the router you want to set the Quake rule (or whichever) and then use the port that the game or app uses for your TCP and UDP settings. use two different rules if you want to split into TCP and UDP.

I have used this method in the past to defeat a poorly designed router :)

Oh shucks EzPimpinYa :P

Tex2002ans
Registered user
Registered user
Posts: 245
Joined: Fri Nov 10, 2006 6:33 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by Tex2002ans » Tue Jul 20, 2010 8:49 pm

firecat wrote:Everytime W7 updates it messes with my routers MAC address
That is impossible, a simple Windows 7 update couldn't change your router's MAC address... if anything it might change the IP address of your computer since you may have it automatically assigned to you (DHCP).
Thelastboyscout wrote:Other info
Router : Netopia
Im using Windows XP Pro with Windows Firewall
Any more detail on the specific router besides Netopia?

If you could please try to answer all of the questions posed in the first post that would be great, thanks. :D

Zewarrior
Registered user
Registered user
Posts: 541
Joined: Sat Oct 04, 2003 2:05 pm
Been thanked: 4 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by Zewarrior » Tue Jul 20, 2010 9:35 pm

^ Go through this and substitute your emule TCP and UDP ports with the examples given. http://www.netopia.com/support/hardware ... G_025.html

Tex2002ans
Registered user
Registered user
Posts: 245
Joined: Fri Nov 10, 2006 6:33 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by Tex2002ans » Tue Jul 20, 2010 11:42 pm

Thelastboyscout wrote:1.Im using Emule v1.2e
First off, I think you are using Emule Plus, NOT Emule.

I would recommend changing to Emule, or one of the mods (I personally use Morph XT):

http://www.emule-project.net/home/perl/general.cgi?l=1
Thelastboyscout wrote:2.My modem is Conexant 850 56K V.9K DFVc
Im connected to a router(Netopia 2247 NWG-VGx Eircom Firmware)
Follow this guide:

http://portforward.com/english/routers/ ... /eMule.htm
Thelastboyscout wrote:3.Im using Windows XP Pro
McAfee Security Centre,My Windows Firewall is turned off
Here is the portfoward's guide to McAfee Security Center. If the first guide doesn't give you High ID, what you usually want to do is completely get rid of the rules created in the firewall, and do them over:

http://portforward.com/english/routers/ ... MuleIn.htm

Tex2002ans
Registered user
Registered user
Posts: 245
Joined: Fri Nov 10, 2006 6:33 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by Tex2002ans » Wed Jul 21, 2010 7:47 am

Thelastboyscout wrote:I tried for ages but getting nowhere fast
Il try a few more times then im giving up... :x
Did you switch over to Emule instead of Emule Plus? :D

Tex2002ans
Registered user
Registered user
Posts: 245
Joined: Fri Nov 10, 2006 6:33 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by Tex2002ans » Wed Jul 21, 2010 2:39 pm

Thelastboyscout wrote:When im port forwarding it says i need the pro version for the static IP
Pro version of what exactly?

soporific
Software Moderator
Software Moderator
Posts: 100
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 9 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by soporific » Thu Aug 26, 2010 5:33 am

koggo.xeth wrote: 5) what you have already done to try to achieve a HighID.
Yes i have tried everything i can ...... as well i have another phone that has the same service but its not a blackberry and i get high ID on it but thats my wife phone
So when you use your wife's phone, you get a high ID, but not with the blackberry ?? If this is the case, we need to work out what it is about your blackberry that is stopping the high ID. This is a new area for me, so we'll be starting from scratch to fix this :)

TSM
Registered user
Registered user
Posts: 52
Joined: Sat Oct 11, 2008 8:31 am
Has thanked: 130 times
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by TSM » Fri Oct 22, 2010 7:32 am

Is the Doctor still in?

I have a 2M Broadband Cable Connection. OS is Win XP International Edition SP3.

Running on a Lenovo with 3 gig memory and 3.5T external storage.

My speed test indicates I hit about 1.9 Meg on downloads and 245K on uploads.
http://www.speedtest.net/

My modem is a COSHIP CCM6220.
http://www.coship.com/en/ProductView.aspx?id=234&sid=71

I am running Peerblock 1.0.

My firewall is COMODO 5.0.162636.1135 and it has been configured using the tutorial at:
http://forums.comodo.com/frequently_ask ... 735.0.html

I am using eMule Extreme version 7.2 on a base of eMule v0.49c.

When I set uPnP to on, eMule does not recognize the modem as being configurable and errors out leaving me with a low ID.

The patient is slipping Doctor and in danger of requesting help from Dr. Death. :banghead

Please help.

demonwizz
Registered user
Registered user
Posts: 3093
Joined: Wed Nov 14, 2007 7:35 pm
Been thanked: 8 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by demonwizz » Fri Oct 22, 2010 5:11 pm

Did you setup static ip address ? If not then you need to do that and in router forward ports to your pc (with this static ip address).
This tutorial is excellent and i'm using it without any problem.

TSM
Registered user
Registered user
Posts: 52
Joined: Sat Oct 11, 2008 8:31 am
Has thanked: 130 times
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by TSM » Fri Oct 22, 2010 6:44 pm

demonwizz wrote:Did you setup static ip address ? If not then you need to do that and in router forward ports to your pc (with this static ip address).
This tutorial is excellent and i'm using it without any problem.
I went to the 'Port Forwarding' site and downloaded the application used for making a static IP and executed it. It now shows that the IP is static.

I have tried executing after restarting eMule with and without uPnP and still get errors. (Unable to forward Ports)

I have been unable to log onto my Cable Modem by issuing the IP address in the URL bar in my browser so I am at a loss as to how I should 'manually' forward my ports because of this.

I reviewed the manual for my Cable Modem and there doesn't seem to be a section on how to log into the modem itself. (Maybe it's something set by my ISP ... I don't know)

I have also tried setting the ports to the defaults and a couple of random port numbers.

demonwizz
Registered user
Registered user
Posts: 3093
Joined: Wed Nov 14, 2007 7:35 pm
Been thanked: 8 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by demonwizz » Fri Oct 22, 2010 7:09 pm

http://portforward.com/networking/static-xp.htm Here is nice manual how to setup static ip address for xp.

In step 2 and step 3 : "open command prompt and type ipconfig /all" then you'll se default gateway address and that is your modem/router address

TSM
Registered user
Registered user
Posts: 52
Joined: Sat Oct 11, 2008 8:31 am
Has thanked: 130 times
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by TSM » Sat Oct 23, 2010 12:48 am

demonwizz wrote:http://portforward.com/networking/static-xp.htm Here is nice manual how to setup static ip address for xp.

In step 2 and step 3 : "open command prompt and type ipconfig /all" then you'll se default gateway address and that is your modem/router address
Okay, did that and confirmed that I DO have a static IP.

One WIERD thing that I did notice was tht the IP address and the Default Gateway differ by more than just the last number. The IP address is 58.31.3.99 while the Default Gateway is 58.31.0.1. AND, as you can see by me still being able to post, it has not effected my connection. (That I know of) But neither one of these IP Addresses will allow me into the set-up of my cable modem.

ginger
Registered user
Registered user
Posts: 712
Joined: Thu Sep 13, 2007 11:09 am
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by ginger » Thu Nov 11, 2010 8:34 pm

padrecovsky wrote: I've only been having problems for the last few weeks.
Have you tried a different router? (I read somewhere that the d-link doesn't like kad)
Enable/disable UPnP?
:?
Are you sure it's not your ISP? To be honest, that was the first thing that came to mind after reading your post. Is it usual for ISP's to throttle/shape in your country?

demonwizz
Registered user
Registered user
Posts: 3093
Joined: Wed Nov 14, 2007 7:35 pm
Been thanked: 8 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by demonwizz » Fri Nov 12, 2010 6:08 pm

padrecovsky wrote: I've only been having problems for the last few weeks.

It goes without saying that i've created a lot of rules in the firewall but that didn't work too.
If you have played with ports in port forward settings check that you have same TCP and UDP ports in router, FortKnox and in emule.

demonwizz
Registered user
Registered user
Posts: 3093
Joined: Wed Nov 14, 2007 7:35 pm
Been thanked: 8 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by demonwizz » Sat Nov 13, 2010 12:18 pm

You can disable Port Scan Protection in your router firewall.

demonwizz
Registered user
Registered user
Posts: 3093
Joined: Wed Nov 14, 2007 7:35 pm
Been thanked: 8 times

Re: The LowID Clinic -- a support thread for LowID problems

Post by demonwizz » Mon Nov 15, 2010 5:14 pm

padrecovsky wrote:i'm connecting to the internet with a router, D-Link DSL-G604T.
padrecovsky wrote:
demonwizz wrote:You can disable Port Scan Protection in your router firewall.
After looking all around for that i did not find such an option in the router firewall :cry:

8-)
Image

Image from D-Link DSL-G604T manual. Page 50.

RDGiant
Newly registered user
Newly registered user
Posts: 5
Joined: Wed Nov 03, 2010 12:08 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by RDGiant » Sun Nov 28, 2010 4:30 pm

padrecovsky,

You said: "I also tried to disconnect the router firewall, and when i do that, i stop getting access to the internet, so that's not a solution"

First of all you must be sure about your router:

1. CONNECT DIRECTLY TO INTERNET: connect the Internet cable directly to your eMule computer. Turn off the eMule computer firewall, all of them (you said: "The Firewall is FortKnox, the XP firewall is turned off").

2. CHECK INTERNET FIRST: open Google page after the cache is cleaned in your Internet Explorer, if it is OK try your eMule: TEST PORTS first (check your TCP and UDP ports), and then connect eMule for HighID - with AND without protocol obfuscation;

If the problem stands: your ISP changed its config (maybe a simple thing such as new DNS servers or new gateway not in your trusted network), if Internet works fine and eMule not - then your eMule config maybe is also bad;

3. CONNECT THRU ROUTER: re-connect the router after a HOT START. OPEN ports in the firewall router, and FORWARD ports (usually, D-Link has SEPARATED menus for Firewall AND Forwarding) in the router.

3.1 By the way what about your ServerUDPPort declared in Preferences.ini of Emule/config folder. If ServerUDPPort=65535 then eMule chooses a port randomly (router/firewall don't know which one), any other number it will be a fixed port (open/forward it too). This port is used for an UDP communication to ed2k servers including search purposes. A lot of people FORGET TO OPEN/FORWARD this port - they get poor search results - last weeks I detected that if you have some FAKE servers in your serverlist panel, they can harm your eMule communication;


4. CHECK INTERNET FIRST: open Google page after the cache is cleaned in your Internet Explorer, if it is OK try your eMule: TEST PORTS first (check your TCP and UDP ports), and then connect eMule for HighID - with AND without protocol obfuscation;

If the problem stands: maybe your router is the problem (if your eMule config is OK) - you can try:
4.1 REDUCE NUMBER OF MAX. CONNECTIONS in eMule Options - usually less than 128 (tip: divide 256 per number of computers that use your router);
4.2 Try both: check and uncheck "Use UPnP to Setup Ports" in both eMule and Router;
4.3 REDUCE MAX. NEW CONNECTIONS / 5 secs.: in eMule Options, Extended;


5. CONNECT THRU ROUTER AND FIREWALL: Turn on the eMule computer firewall, just the one you use (you said: "The Firewall is FortKnox, the XP firewall is turned off"). OPEN THE SAME ports you opened/forwarded in the router. Don't be so hard in the protocol rules. I strongly suggest to re-start your computer after config the firewall.

6. CHECK INTERNET FIRST: open Google page after the cache is cleaned in your Internet Explorer, if it is OK try your eMule: TEST PORTS first (check your TCP and UDP ports), and then connect eMule for HighID - with AND without protocol obfuscation;

If the problem stands: maybe your firewall config is the problem (if your eMule config is OK, maybe the last update of your firewall is making a mess) - you can try:
6.1 Turn off the eMule computer firewall, turn on back XP firewall - and do new test - just to be sure the problem is a specific firewall;
6.2 Visit the Firewall forum for specific rules for eMule and P2P networks, you will be surprise how many rules you need to apply including ICMP, etc. If you can't find for "FortKnox", try the equivalent "COMODO" rules in the COMODO forum - do not forget to add a rule for ServerUDPPort (different from 65535);

Post the results of your tests here.

Good emuling to you all.

TSM
Registered user
Registered user
Posts: 52
Joined: Sat Oct 11, 2008 8:31 am
Has thanked: 130 times
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by TSM » Mon Nov 29, 2010 2:28 am

Since the last time I posted here I have upgraded my OS to Windows 7 Ultimate, Upgraded eMule to 50a with Xtreme 8, upgraded Peerblock to 1.1, Got a new D-Link DIR-655 and a 2 meg Cable connection (Tested at 1.80 Mb per sec. Up ~ .44 Mb per sec. Dn).

My IP is static and I have performed port forwarded manually on my router as per: http://portforward.com/english/routers/ ... /eMule.htm

I tried using PnP with no good results.

I am using the standard windows firewall and AVG free as my Virus Guard.

Although my router does Gigabit wireless, I am hardwired.

I have tried testing ports with eMule and http://portforward.com/help/portcheck.htm with no result.

Have I forgotten ANYTHING!?

RDGiant
Newly registered user
Newly registered user
Posts: 5
Joined: Wed Nov 03, 2010 12:08 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by RDGiant » Mon Nov 29, 2010 6:32 pm

TSM, let me see if I can help you... I read all your posts and the related Demonwizz posts.

I suppose that Troubleshooting I posted on Nov 28 (see previous page) to padrecovsky didn't help you on anything... I believe that troubleshoot could help to find (at least) where is the bottleneck for Emulers behind routers and firewalls.

A direct connection from your Emule computer to Internet could tell us few things (but IP cannot be static).

-----------------------------------------------------------
You said: "The IP address is 58.31.3.99 while the Default Gateway is 58.31.0.1..." and "but neither one of these IP Addresses will allow me into the set-up of my cable modem".

Yes, for sure, that is right: usually the (TV/DSL) Cable Modems have RESERVED INTERNAL IPs too (192.168.x.x) - they do not conflict to your internal network because they are outside from your router LAN management, but under your ISP Gateway WAN management.

You DON'T NEED IT for anything but you have the right to know (JUST FOR FUN, having nothing to do with eMule):
1. COSHIP CCM6220 the most usual IPs are 192.168.100.1 (same as Motorola modems), 192.168.0.1 (the same as your new router? if yes, you must connect directly to the modem), 192.168.1.1 (I saw this IP too for Coship in Asia);

2. COSHIP CCM6220 the most usual Passwords are "0000" (default, try 4 zeroes first), then add one zero at a time (some ISPs change);

-----------------------------------------------------------
You didn't say anything about a router in your first post, but you said on 4th post: "Got a new D-Link DIR-655".

A) DIR-655 is one of the best SOHO routers at this time... BUT IT IS A SOHO (Small Office Home Office) yet, and most of SOHO routers has limited number of connections (usual: 256 to 512), so my previous post applies:
4.1 REDUCE NUMBER OF MAX. CONNECTIONS in eMule Options - usually less than 128 (tip: divide 256 per number of computers that use your router, but for DIR655 you can try to divide 512) - my experience with D-Link SOHO routers advises a number as low as 64 max-connections HARDWIRED, even less for Wireless;

B) If you like: test the quality of your router trying to access some Microsoft Multimedia Servers (IP television sites with mms://), wireless first, then hardwired - the time without freezing/flashing lights will tell you how good is your DIR-655;

C) You DON'T NEED a static IP (since your eMule computer is always-on and it has hardwired connection to LAN port 1 of DIR-655 - your eMule computer always get 192.168.0.100). Keep it if you like it, since you don't need to change your Router Firewall/Forwarding config everytime your router re-starts, it is a confortable zone. But, if the router re-starts so much you need to check the items A) and B) above. I like to use a long DHCP time such as 86400 minutes (number good for logging);

D) But do not forget to Forward AND config the router firewall, so my previous post applies:
3. CONNECT THRU ROUTER: OPEN ports in the firewall router, and FORWARD ports (usually, D-Link has SEPARATED menus for Firewall AND Forwarding) in the router.

On Port Forwarding: forward an set of ports (instead individual ports) for both TCP/UDP: eMule TCP port, eMule UDP port, ServerUDPPort (ah, maybe you forgot that one, read my previous post), eMule Web interface port (if you use it). Mobilemule uses a privileged port if you use it, create a separate rule for it;

I suggest a trigger in D-Link Application Rules: the trigger will be the eMule TCP port for the same set of ports in the Port Forwarding. No need DMZ;


E) Don't be so hard about protocol in your router (and firewall) you can enable: all VPN protocols passthrough, UPnP, Gaming modes, Multicast streams, etc. For security reasons just keep WAN ping respond disabled;

-----------------------------------------------------------
You said: "I am using... AVG free as my Virus Guard."

If you have LinkScanner active, GET RID of that goddamn thing off. No use if you just de-activate - you must uninstall AVG free (fully, with AVG removal tool if necessary) and re-install it uncheking the LinkScanner, you will be grateful for your NEW BANDWIDHT.

-----------------------------------------------------------
Your first post: "OS is Win XP International Edition SP3... My firewall is COMODO 5.0.162636.1135 and it has been configured using the tutorial at:
http://forums.comodo.com/frequently_ask ... 735.0.html";

Your last post: "I have upgraded my OS to Windows 7 Ultimate... I am using the standard windows firewall "

I TESTED BOTH configurations behind a SOHO D-Link router SUCCESSFULLY: I prefer WinXP+Comodo to Win7+WinFirewall, I have more control of my dedicated eMule computer. For you current Win7+WinFirewall platform, I had to create 2 rules: EmuleTCP and EmuleUDP, both:
1. Allow the Connection - (in General);
2. related to emule.exe ONLY - (in Programs and Services);
2. Local: set of your TCP and UDP ports (same as router) and Remote port: ALL - (in Protocols and Ports);
3. Local and Remote address: ANY IP ADDRESS - (in Scope - EVEN if you have Static IP, Windows sometimes refers to 127.0.0.1 as the local);
4. Profiles: Private AND Public - (in Advance);
5. Inteface Types: ALL - (in Advance);
6. Edge Tranversal: Defer to User - (in Advance);

AND RESTART the computer (before restart I didn't get the eMule connection);

-----------------------------------------------------------
Your first post: "When I set uPnP to on, eMule does not recognize the modem as being configurable and errors out leaving me with a low ID";

Other post: "I have tried executing after restarting eMule with and without uPnP and still get errors. (Unable to forward Ports)";

The eMule UPnP works only if both eMule TCP and UDP ports are open/forwarded in a correct way. Test your ports in eMule, you don't need to connect eMule. Check if your D-link router has UPnP enabled.

I don't believe eMule is trying to recognize your modem (since the Cable modem is transparent to the network), the UPnP is trying to recognize your ISP Gateway as an UPnP router if you are directly connected to Internet, or your brand new DIR-655, if you not.

Be focused on the port forwarding only... and behind your router UPnP will work fine as magic.

Even if you don't have UPnP working you still can get a HighID, but most of the experts suggest that if you don't get UPnP working behind a router then it is advisable to disable UPnP in the eMule (you can keep it enabled in router).

Good Emuling.
(sorry for long posts, Emulers: too much info to be concise).
Last edited by RDGiant on Mon Nov 29, 2010 8:45 pm, edited 2 times in total.

TSM
Registered user
Registered user
Posts: 52
Joined: Sat Oct 11, 2008 8:31 am
Has thanked: 130 times
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by TSM » Mon Nov 29, 2010 10:39 pm

Hey ... thanks for all the help!

It will have to wait until tonight before I can give it justice. I'm just getting ready for work.

I see a few things in there that just might be my answer!!!

And don't worry about the long post. You make me feel like I am getting my money's worth. :wink:

TSM
Registered user
Registered user
Posts: 52
Joined: Sat Oct 11, 2008 8:31 am
Has thanked: 130 times
Been thanked: 1 time

Re: The LowID Clinic -- a support thread for LowID problems

Post by TSM » Wed Dec 01, 2010 7:26 am

Just to confirm and apologize for the confusion, I completely reconfigured my system partially to see if I could achieve the illusive 'high ID' and also because the little woman (She's Chinese and she is little) decided to hook up her Vaio ... Hence the new router. I had never managed a high ID even when I was directly hooked into the cable modem.
RDGiant wrote:TSM, let me see if I can help you... I read all your posts and the related Demonwizz posts.

I suppose that Troubleshooting I posted on Nov 28 (see previous page) to padrecovsky didn't help you on anything... I believe that troubleshoot could help to find (at least) where is the bottleneck for Emulers behind routers and firewalls.

A direct connection from your Emule computer to Internet could tell us few things (but IP cannot be static).
I suppose it does not bode well that I previously tried to connect without a router or firewall at all in the previous incarnation of my system and only got a low ID.

That is why I have not pushed this much in the recent past.

I am assuming that the 'problem' may be my ISP however, I thought I'd give it the old college try in case the 'problem' is my ignorance.
RDGiant wrote: -----------------------------------------------------------
You said: "The IP address is 58.31.3.99 while the Default Gateway is 58.31.0.1..." and "but neither one of these IP Addresses will allow me into the set-up of my cable modem".

Yes, for sure, that is right: usually the (TV/DSL) Cable Modems have RESERVED INTERNAL IPs too (192.168.x.x) - they do not conflict to your internal network because they are outside from your router LAN management, but under your ISP Gateway WAN management.

You DON'T NEED IT for anything but you have the right to know (JUST FOR FUN, having nothing to do with eMule):
1. COSHIP CCM6220 the most usual IPs are 192.168.100.1 (same as Motorola modems), 192.168.0.1 (the same as your new router? if yes, you must connect directly to the modem), 192.168.1.1 (I saw this IP too for Coship in Asia);

2. COSHIP CCM6220 the most usual Passwords are "0000" (default, try 4 zeroes first), then add one zero at a time (some ISPs change);
Good to know ... Thanks for that.
RDGiant wrote: -----------------------------------------------------------
You didn't say anything about a router in your first post, but you said on 4th post: "Got a new D-Link DIR-655".

A) DIR-655 is one of the best SOHO routers at this time... BUT IT IS A SOHO (Small Office Home Office) yet, and most of SOHO routers has limited number of connections (usual: 256 to 512), so my previous post applies:
4.1 REDUCE NUMBER OF MAX. CONNECTIONS in eMule Options - usually less than 128 (tip: divide 256 per number of computers that use your router, but for DIR655 you can try to divide 512) - my experience with D-Link SOHO routers advises a number as low as 64 max-connections HARDWIRED, even less for Wireless;

B) If you like: test the quality of your router trying to access some Microsoft Multimedia Servers (IP television sites with mms://), wireless first, then hardwired - the time without freezing/flashing lights will tell you how good is your DIR-655;
Is the above relative to tuning or to obtaining a high ID?
RDGiant wrote: C) You DON'T NEED a static IP (since your eMule computer is always-on and it has hardwired connection to LAN port 1 of DIR-655 - your eMule computer always get 192.168.0.100). Keep it if you like it, since you don't need to change your Router Firewall/Forwarding config everytime your router re-starts, it is a confortable zone. But, if the router re-starts so much you need to check the items A) and B) above. I like to use a long DHCP time such as 86400 minutes (number good for logging);
Currently, I am forwarding ports via the router and not with uPnP so the router should handle this on a reconnect, shouldn't it?
RDGiant wrote:
D) But do not forget to Forward AND config the router firewall, so my previous post applies:
3. CONNECT THRU ROUTER: OPEN ports in the firewall router, and FORWARD ports (usually, D-Link has SEPARATED menus for Firewall AND Forwarding) in the router.

On Port Forwarding: forward an set of ports (instead individual ports) for both TCP/UDP: eMule TCP port, eMule UDP port, ServerUDPPort (ah, maybe you forgot that one, read my previous post), eMule Web interface port (if you use it). Mobilemule uses a privileged port if you use it, create a separate rule for it;
in your previous post you state: "By the way what about your ServerUDPPort declared in Preferences.ini of Emule/config folder. If ServerUDPPort=65535 then eMule chooses a port randomly (router/firewall don't know which one), any other number it will be a fixed port (open/forward it too). "

Does this mean we should change the number so we get a 'fixed port' and then forward that port? It stands to reason that if we leave it as 65535 and it generates a new one each time it comes up then we would not be able to forward a constantly changing number.

Also, I don't see much to configure on the Router Firewall Menu.
There is :
There is: wrote:Firewall Settings

Enable SPI : (Set to ON)

NAT Endpoint Filtering

UDP Endpoint Filtering:
  • Endpoint Independent
  • Address Restricted (Set to ON)
  • Port And Address Restricted
TCP Endpoint Filtering:
  • Endpoint Independent
  • Address Restricted
  • Port And Address Restricted (Set to ON)
Anti-Spoof checking
  • Enable anti-spoof checking: (Set to OFF)
DMZ Host

The DMZ (Demilitarized Zone) option lets you set a single computer on your network outside of the router. If you have a computer that cannot run Internet applications successfully from behind the router, then you can place the computer into the DMZ for unrestricted Internet access.

Note: Putting a computer in the DMZ may expose that computer to a variety of security risks. Use of this option is only recommended as a last resort.
  • Enable DMZ: (Set to OFF)
  • DMZ IP Address : Blank 0.0.0.0
Application Level Gateway (ALG) Configuration
  • PPTP : (Set to ON)
  • IPSec (VPN) : (Set to ON)
  • RTSP : (Set to ON)
  • SIP : (Set to ON)
Is the Above Correct?
RDGiant wrote:
I suggest a trigger in D-Link Application Rules: the trigger will be the eMule TCP port for the same set of ports in the Port Forwarding. No need DMZ;
Okay ... I have assumed that we are dealing with another UDPServer than 65539 and I have replaced that number with my own port and hard coded it into the preferences file. So ... I now forward the three ports and have 3 triggers.
RDGiant wrote: -----------------------------------------------------------
You said: "I am using... AVG free as my Virus Guard."

If you have LinkScanner active, GET RID of that goddamn thing off. No use if you just de-activate - you must uninstall AVG free (fully, with AVG removal tool if necessary) and re-install it uncheking the LinkScanner, you will be grateful for your NEW BANDWIDHT.
You're right ... I AM grateful. Much better.
RDGiant wrote: -----------------------------------------------------------
Your first post: "OS is Win XP International Edition SP3... My firewall is COMODO 5.0.162636.1135 and it has been configured using the tutorial at:
http://forums.comodo.com/frequently_ask ... 735.0.html";

Your last post: "I have upgraded my OS to Windows 7 Ultimate... I am using the standard windows firewall "

I TESTED BOTH configurations behind a SOHO D-Link router SUCCESSFULLY: I prefer WinXP+Comodo to Win7+WinFirewall, I have more control of my dedicated eMule computer. For you current Win7+WinFirewall platform, I had to create 2 rules: EmuleTCP and EmuleUDP, both:
1. Allow the Connection - (in General);
2. related to emule.exe ONLY - (in Programs and Services);
2. Local: set of your TCP and UDP ports (same as router) and Remote port: ALL - (in Protocols and Ports);
3. Local and Remote address: ANY IP ADDRESS - (in Scope - EVEN if you have Static IP, Windows sometimes refers to 127.0.0.1 as the local);
4. Profiles: Private AND Public - (in Advance);
5. Inteface Types: ALL - (in Advance);
6. Edge Tranversal: Defer to User - (in Advance);

AND RESTART the computer (before restart I didn't get the eMule connection);
I am a n00b with Windows 7 so you will have to spell this out for me. I have no idea where to access this info or change it. Sorry :oops:
RDGiant wrote: -----------------------------------------------------------
Your first post: "When I set uPnP to on, eMule does not recognize the modem as being configurable and errors out leaving me with a low ID";

Other post: "I have tried executing after restarting eMule with and without uPnP and still get errors. (Unable to forward Ports)";

The eMule UPnP works only if both eMule TCP and UDP ports are open/forwarded in a correct way. Test your ports in eMule, you don't need to connect eMule. Check if your D-link router has UPnP enabled.

I don't believe eMule is trying to recognize your modem (since the Cable modem is transparent to the network), the UPnP is trying to recognize your ISP Gateway as an UPnP router if you are directly connected to Internet, or your brand new DIR-655, if you not.

Be focused on the port forwarding only... and behind your router UPnP will work fine as magic.

Even if you don't have UPnP working you still can get a HighID, but most of the experts suggest that if you don't get UPnP working behind a router then it is advisable to disable UPnP in the eMule (you can keep it enabled in router).

Good Emuling.
(sorry for long posts, Emulers: too much info to be concise).
Thanks a hell of a lot by the way. The task is a bit daunting but as soon as I get clarification on where to perform those last few tasks, I think I'll be good to go.

*Or my ISP is messing me around. :x

RDGiant
Newly registered user
Newly registered user
Posts: 5
Joined: Wed Nov 03, 2010 12:08 am

Re: The LowID Clinic -- a support thread for LowID problems

Post by RDGiant » Wed Dec 01, 2010 7:53 pm

>>TSM wrote:
I suppose it does not bode well that I previously tried to connect without a router or firewall at all in the previous incarnation of my system and only got a low ID.

hmmmm... it explains why you want to access your modem and you're suspicious of your ISP. And the previous incarnation was WinXP+Comodo, right? and I suppose when you disabled/uninstalled the Comodo firewall the WinXP firewall DID NOT TURN ON automatically... so my suggestions are...

... in the meantime, after the little Chinese woman of yours stops to chat on QQ and before she requests your presence on the bed to comply to your duties (I have experience with little Chinese women myself) you should try:

1. CONNECT DIRECTLY TO INTERNET: connect the Internet cable directly to your eMule computer.
1.1 Turn off the eMule computer firewall, all of them (in the current incarnation: Win7 firewall);

>>TSM wrote:
I am a n00b with Windows 7 so you will have to spell this out for me. I have no idea where to access this info or change it.

1.1.1 Click [Start] button for Start Menu;
1.1.2 Type "firewall" in [Search programs and files ];
1.1.3 Click "Windows Firewall" in "Control Panel (x)" section of the search result: [Control Panel\All Control Panel Items\Windows Firewall] window shows up;
1.1.4 Click "Turn Windows Firewall on or off" (left blue text bar);
1.1.5 Select (o)Turn off Windows Firewall (not recommended) in both sections: "Home or work(private)" and "Public" network location settings;
1.1.6 Accept the changes (even with warnings, if any);

1.2 Remove all your fixed IP settings - it is advisable to set the DNS provided by your ISP, or look for good DNS servers in Google;
1.3 RESTART the computer;


2. CHECK INTERNET FIRST: open Google page after the cache is cleaned in your Internet Explorer;


3. SETTING EMULE UP:
>>TSM wrote:
Does this mean we should change the number so we get a 'fixed port' and then forward that port? It stands to reason that if we leave it as 65535 and it generates a new one each time it comes up then we would not be able to forward a constantly changing number.

3.1 YES, you understood PERFECTLY!!!! But let's set an eMule Port Range to keep the things easy, OK? Let's say you are using eMule DEFAULT PORTS:
TCP: 4662 UDP: 4672
3.1.1 Copy & paste Preferences.ini in Emule/config folder (DO NOT start eMule) for backup, just in case;
3.1.2 Open (Edit) Preferences.ini (the original one);
3.1.3 Change from ServerUDPPort=65535 to ServerUDPPort=4667 (or a port nearby the 4662-4672 range);
3.1.4 Close (Save) Preferences.ini;

3.2 Open eMule, click "Options":
3.2.1 Click "Connection" tab;
3.2.2 Check if TCP and UDP ports are TCP[4662 ] & UDP[4672 ] (as our case here);
3.2.3 UNCHECK [_]Use UPnP to Setup Ports (this is good if you have full control of the router, but at this time, you are behind ISP router);
3.2.3 UNCHECK [_]Autoconnect on startup (if it was checked, eMule is trying to connect, stop it);
3.2.4 CHECK BOTH: [v]Kad & [v]eD2K;

3.2.5 Click "Proxy" tab;
3.2.6 UNCHECK [_]Enable proxy (assuming you are not behind a proxy);

3.2.7 Click "Server" tab;
3.2.8 UNCHECK [_]Auto-update server list at startup;
3.2.9 CHECK: [v]Use smart LowID check on connect;
3.2.10 CHECK: [v]Safe Connect;

3.2.11 Click "Security" tab;
3.2.12 CHECK: [v]Filter server too;
3.2.13 Check if Filter level: < [127 ];
3.2.14 Copy link: http://en.emulehelp.com/ipfilter.dat.gz (this is most reliable IP Filter - provided by Original eMule Developers);
3.2.15 Paste into "Update from URL:...";
3.2.16 Click [ Load ], and wait for the download to be completed - it is a simple HTTP-80tcp port traffic, if Internet Explorer works, it should works;
3.2.17 Click [ Reload ] just in case;
3.2.18 CHECK: [v]Enable protocol obfuscation (UNCHECK other stuff in Protocol Obfuscation section);

3.2.19 Click "Web Interface" tab;
3.2.20 UNCHECK [_]Include port into UPnP setup;
3.2.21 Change Port[???? ] to Port[4668 ] (or a port nearby the 4662-4672 range);

3.2.22 Click "Extended" tab;
3.2.23 CHECK: [v]Fast connection reject (in "TCP/IP connections" section);
3.2.24 CHECK: [v]Filter server and client LAN IPs;
3.2.25 CHECK: [v]Show more controls (advance mode controls);
3.2.26 UNCHECK [_]Use UPnP to Setup Ports; (ah! you forgot this one in your Xtreme mod, isn't it? It is in "UPnP" section);
3.2.27 UNCHECK THEM ALL in "UPnP" section;

3.2.28 Click "Xtreme I" tab;
3.2.29 CHECK: [v]NAFC Full Control U/D Limits;
3.2.30 Fill MTU field, if you know which your MTU is, if not keep default [1340 ] - you can do it later;

3.3 RESTART eMule;


4. CLEANING EMULE:
4.1 in "Servers" panel, select ALL servers;
4.2 Right-click for menu;
4.3 Click "Remove All";
4.4 Copy link: http://en.emulehelp.com/server.met (this is most reliable server.met - provided by Original eMule Developers);
4.5 Paste into "Update server.met from URL";
4.6 Click [ Update ], and wait for the download to be completed - it is a simple HTTP-80tcp port traffic, if Internet Explorer works, it should works. I assume you will have 7-10 servers listed, and "eDonkeyServer No2" is one of them. Maybe a bad serverlist full of fake servers was your problem from the begining;


5. TESTING EMULE PORTS:
5.1 Open eMule, click "Options":
5.2 Click "Connection" tab;
5.3 Click [ Test Ports ];
5.4 Wait for the Internet Explorer complete the test - it is a simple HTTP-80tcp port request to the eMule site test your TCP and UDP ports from outside. The results can be:
5.4.1 All ports green - you can proceed to the connection;
5.4.2 TCP port green, UDP port red - you can proceed to the connection, you will get HighID in eD2K, but firewalled status in Kad;
5.4.3 TCP port red, UDP port is NOT tested - you will get LowId if connected, and Kad status is unknown;

5.5 I see no reasons for problems in Port Testing since you have no router neither firewall, and correct eMule config (as far as I know). In case your ISP is giving you trouble you can try to change the ports as below - [Test Ports] after [Apply] changes in eMule Options:
5.5.1 Try (ports >4000, already tested as above):
ServerUDPPort=4667 (in Preferences.ini, eMule turned off);
TCP: 4662 UDP: 4672 Web Interface: 4668 (in eMule Options);

5.5.2 Try ports >8000 (tested above):
ServerUDPPort=9667 (in Preferences.ini, eMule turned off);
TCP: 9662 UDP: 9672 Web Interface: 9668 (in eMule Options);

5.5.3 Try ports >16000:
ServerUDPPort=17667 (in Preferences.ini, eMule turned off);
TCP: 17662 UDP: 17672 Web Interface: 17668 (in eMule Options);

5.5.4 Try ports >32000:
ServerUDPPort=33667 (in Preferences.ini, eMule turned off);
TCP: 33662 UDP: 33672 Web Interface: 33668 (in eMule Options);

5.5.5 Try ports >48000:
ServerUDPPort=49667 (in Preferences.ini, eMule turned off);
TCP: 49662 UDP: 49672 Web Interface: 49668 (in eMule Options);

>>TSM wrote:
I thought I'd give it the old college try in case the 'problem' is my ignorance.

Probably they have a router under their control, complete firewalled, maybe it is not a good test. You could try at friend's or neighbour's in an open router-free Internet. If it works: CHANGE YOUR (goddamn bastard) ISP!!!! If your ISP is so bad maybe its IP range is blocked in the IP Filter.

If eMule doesn't work outside your home: you still have problems with your eMule config.


6. CONNECTING EMULE: let's say you passed thru the Port Testing all green... let's connect:
6.1 in "Servers" panel, DO NOT click [ Connect ] button at up-right corner;
6.2 Double-click "eDonkeyServer No2" (the best server to connect), be patient, eMule will try 2 or 3 times;
6.3 If you get HighID, proceed to Kad connection. If you still get LowID or no connection proceed as below:
6.4 Sort Server list per ping (ascending), click [Ping ^] column;
6.5 Double-click first server (lower ping), be patient, eMule will try 2 or 3 times - if you get HighID, proceed to Kad connection. If you still get LowID, double-click next server. Try 3 low-ping servers, at least. If LowID stands, try [ Connect ] button - and no matter the results proceed to Kad connection;

6.6 in "Kad" panel, click [ Connect ] button at up-right corner;
6.7 Wait few seconds for nodes. If there are few nodes (or none) then copy link: http://www.nodes-dat.com and paste to "Nodes.dat from URL", and select it - reconnect Kad;
6.8 Wait few minutes for the green arrow near by "Kad:Connected" in status bar. If the arrow is red or yellow then click [ Recheck Firewall ] and wait few seconds and if arrow stills click again;


That is enough for today, TSM... if you can pass thru all these then reconnect your router for your little Chinese woman so she can chat back in QQ, and later we will set up your DIR-655 (I already have the config parameters) and Win7 Firewall with the Port Range you selected, step by step.


Good Emuling to you all.

Post Reply

Return to “Technical Support & Discussion”