The LowID Clinic -- a support thread for LowID problems

Your computer feeling a lot slower lately? That new program you installed not working? Can't convert a specific file? Looking to buy a new hard drive or dvd writer? Would like some recommendations? Firewalls, latest threats and general P2P security issues are here also.
Post Reply
soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

The LowID Clinic -- a support thread for LowID problems

Post by soporific » Mon Sep 03, 2007 6:13 am

Hi there,

I am always distressed to hear that people are 'suffering' with their emule connections always failing to achieve a HighID, ie they try to file share using emule with a LowID. Having a low ID does not mean that no upload or download is possible, but it has several disadvantages:
1) No IP is known of the machine eMule is running on, therefore all requests, like queue or connection requests to this client, have to be routed over the server the low ID client is connected to. This routing causes considerable amount of CPU load on the server, thus reducing the maximum number of users the server can cope with. Lugdunum’s servers limit the number of low ID users, or even ban all of them.
2) Two clients with low ID cannot connect to each other, as it is not possible to route messages over two different servers. This will lead to less sources for the downloads.
3) On busy servers it may well happen that the messages get lost and eMule misses important information about queue progression or download requests. This may lead to fewer credits and worse downloads.

So its in the best interests of all emule users to help those with lowIDs get HighIDs.

It is not my intention to re-invent the wheel. For those who are having problems, your first port of call is the tutorial on troubleshooting emule problems, which contains an entire section on how to diagnose and fix lowID problems.

Please visit the tutorial here:
http://sharethefiles.com/forum/viewtopic.php?t=66859#1

Also, visit the help section of the official emule site:
http://www.emule-project.net/home/perl/help.cgi?l=1

However, sometimes people need more help, as evidenced by the number of threads with lowID in the title. There's been quite a few recently. I have had lots of experience helping people with this (and i'm sure there's others as well), and i offer my services to any or all that need help.

The aim of this thread is to provide a place for solutions to fixing LowID problems to be collected in the one place. It is my intention to continually revise this first post, collecting and organising all the tips and information about how to go about fixing your lowID problems.

When you post your problem, please include the following information:

1) which version of emule you are using, especially if it is a mod version.
2) your type of internet connection, and model & type of modem. It is imperative you know if you are connected to the internet via a router, or via a modem (whether its a broadband modem, or dial-up). If you don't know this information, it is going to be very hard to help you.
3) your operating system, and a list of all 'security' applications - eg firewalls or 'total internet security' type apps. You generally don't need to list malware programs like "Spybot - Search & Destroy" or anti-virus programs but if in doubt list them all.
4) confirm if you can or cannot log in to your router (if you have one). If you can't log in (or haven't ever done so), this is why you haven't got a HighID. Concentrate on this step if this is the case. If you can't log in, don't worry about anything else, fix this first. We can help you with this, just inform us you can't log in.
5) what you have already done to try to achieve a HighID.
6) most important: please confirm you have visited the Tutorial post (see above) and try to describe where you got up to, or how the tutorial failed to help you. This way we can improve the tutorial and maybe stop the need for threads like these.
7) anything else you consider relevant.
8) please report the result you get from the 'Test ports' feature in emule options (the connection tab)

and so...

The LowID clinic is currently open.


the following is the collected wisdom of advice to previous patients, last updated on 12th February 2010.

The current list of things to check:

The very first thing you should do is reboot or power-cycle your modem if you haven't already tried that. Power-cycling simply means turning the modem off, waiting 20 seconds and then turning it back on. Modems can be quite twitchy -- an entire South Park episode revolved around this -- its a strange but true fact that 95% of problems are resolved by rebooting the modem. Do this first, and check if your issues still exist. If so, keep reading...

1) testing for HighID: the best method is to use the 'test Ports' feature of Emule. This can be found in emule options, the Connection tab: you should see two fields where you can enter what TCP and UDP ports you want to use. And right next to them is the 'Test ports' button. Both the TCP and UDP settings need to pass to get a HighID. Just because you get a pass once, it doesn't mean you will always pass. If you are having problems, check regularly and if you aren't passing then you know where the problem lies. If you ARE passing every time you can rule out problems that relate to port forwarding issues.

2) use the default ports: until you achieve a HighID, i recommend using the default ports which are 4662 for TCP and 4672 for UDP. It is possible that the reason you can't get a HighID is because you are using the default ports (and this means your ISP is trying to block emule --- change ISPs!) but this is rare in my experience so try the default ports first. As soon as you get a HighID for the first time, then change the default ports if you want, but until you have worked out the problem, i recommend using the default port numbers.

3) if you are trying to set up emule on 2 different computers which both use the same internet connection (ie via a router or similar), you need to set different port numbers and forward both sets of ports in your router.

4) make sure your firewall isn't causing the problem: this is relatively easy to check, most firewalls have an easy way to turn the firewall off (or disabling) so you can check if that was the problem. In my experience, it is very rarely the cause of the problem, so get this out of the way early and then focus on other possible sources. ie turn off the firewall, and then use the 'test ports' function in emule.

5) emule at your workplace: this is very very likely to be impossible, and most likely to be not worth the risk/hassle. Please advise if you are experiencing your lowID problems at work, because most likely i can't help you. It still may be possible, i'm just warning here ...

6) understanding your router/broadband modem: please advise if you find your router/broadband modem confusing or hard to understand --- in my experience, some people have said they have "done the port forwarding" when in fact they haven't. Swallow your pride and advise if this is the case. Many many moons ago back in my day, routers were simple things and easy to configure. These days they come with so many features it can get bewildering. There are also different names for 'port forwarding', for example, my router calls it "Virtual servers" --- you may need to make sense of your modems setting names.

7) Use UPnP: Universal Plug n Play (UPnP) is a feature that may save your butt when all else fails. In the same place as the 'test ports' feature in emule, is a setting to "use UPnP to setup ports" --- first, your computer needs to have UPnP enabled. You can find it in your list of Services (go to Administrative tools). Please check to see that it is enabled because some programs (eg TuneUp Utilities) consider it a security risk (which is a valid concern) and disable it. Please see the 3rd post in this thread for instructions on how to turn it on if you don't know how to check. PLEASE NOTE: it is possible to FAIL the "test ports" function, but still get a HighID because UPnP comes to the rescue. In my experience, this happens quite a lot -- ie someone is having problems which disappear once they start using UPnP. In this case, try to connect to a commonly used server (i would try DonkeyServer no2 or no3) and see if you connect with a HighID. Having said that UPnP could save the day, you still should try to work out how to get a HighID WITHOUT using UPnP --- basically, if you are resorting to UPnP to get a HighID, you aren't in control of your router/modem! In my experience, that is ... :)

8) for those with broadband modem/routers, a common mistake is to set your 'port forwarding' settings wrong. There is a sure fire way to make sure you get this right, so follow these steps:
...a... use the IPCONFIG command to show you all your connected network adapters, and this will tell you two things: your PC's LAN address, and also the address of your router. To do this click START -> RUN and in the RUN dialog box, type CMD (and press enter) which will open up a DOS box and this is where you type IPCONFIG
here's a screenshot:

Image

...b... OK lets identify what the screenshot is showing us:

-- the IP address is 10.0.0.9 --- this is the PC's LAN address. This is the address you use in port forwarding. You need to tell the router where to send stuff coming in on the port you want to use. So you need the PC's LAN address.
-- the gateway address is 10.0.0.2 ---- this is the modem/router's address. Think of it like this: why would the modem need to know its own address when setting port forwarding settings? This is an easy way to remember NOT to use this address for your port forwarding settings because it doesn't make sense. However, this is the mistake that some people are making, so this is a sure fire way to avoid it.
-- if you have more than one network adapter, AND you have two or more entries that have an entry for the "Default Gateway" you need to determine which one is your internet connection. You can determine this a number of ways but an easy way is to check is to type the gateway address into your browser and one of them should bring up the login for your modem. The one that does this is the one you want.

...c... Setting your rules. You will need to set two rules: one for TCP and one for UDP. Choose a port number (if the default ports 4662 and 4672 work then use them) and don't forget to ensure it corresponds with the port numbers you set in emule. Some routers ask you for a starting port and finish port. Just use the same number and assign it to TCP and then do it again for UDP but use a different port number to the TCP port number.

...d... that's it, you should have successfully avoided setting your port forwarding settings wrong. :karate

9) become buddies with your router or router/modem (if you have one). If you're not regularly logging into it and checking out how things are, you aren't going to have much luck fixing problems when emule suddenly doesn't work. So, if you can't log in to your router, you need to tell us this because that is what we will focus on to help you. Logging into your router is simple. Use the method in point 8 to do this. You will need to know the username and password of your router. 99% of the time you will be able to use 'admin' for the username and 'admin' for the password if you haven't changed it from the default. Sometimes the password is 'password' so try that if 'admin' doesn't work. This is a security risk if you haven't changed it so i recommend doing this ASAP. The most common things to do once you've logged in are:
* check the line connection is in SYNC (you can see your signal-to-noise connection ratio)
* check that you are connected to the net (you can see your IP address)
* check the current list of forwarded ports
* do a self-test on the router to see if it reports any faults
* and other useful things as well.

So, please remember to tell us if you can't log in to your router.

10) visit this site: http://www.portforward.com/

- even if you don't have a router in the mix, visit anyway as there's heaps of really good info.

11) turn off the firewall in your Internet Security application! Even if you have set rules to allow emule to send and receive which will allow you to get a high ID, sometimes your connection is still affected by other things to do with the 'extra' firewall you have. So, if you think you should be uploading more than you are, or you don't see as many servers as you normally can, try turning off the firewall for a long period of time to see if that helps at all. NOD32 Internet Security is an example of an application that may be causing problems due to the firewall. Just turn it off and use Windows firewall instead.

12) If you have a router, try enabling DMZ
http://img2.timg.co.il/forums/1_135641582.jpg
Last edited by soporific on Tue Feb 10, 2009 12:03 am, edited 17 times in total.

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Sun Sep 16, 2007 7:20 am

To all my new patients, please see the first post for things to try to fix your problem as i have collated all information we've collected so far. Please reply with any additional info and i will try to help you out.

DM-Mac
Newly registered user
Newly registered user
Posts: 2
Joined: Tue Jul 24, 2007 12:42 am

Post by DM-Mac » Sun Sep 23, 2007 12:45 am

I am useing version .48a of emule ,cable connection ,wireless router is a linksys model is wrt54gs,win xp media center version 2002 ,I have tried getting into my router and changeing everything but no luck Please help If I havent given enough info please ask

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Tue Sep 25, 2007 1:04 pm

DM-Mac wrote:I am useing version .48a of emule ,cable connection ,wireless router is a linksys model is wrt54gs,win xp media center version 2002 ,I have tried getting into my router and changeing everything but no luck Please help If I havent given enough info please ask
I'm currently out of the office on an essential extended house call, but you're first in line when i get back.

A quick over-the-phone diagnosis: you say you can't get into your router/modem? Please confirm you've tried reading the manual for your router (sorry to be obvious), and that you've tried to find an FAQ on your modem manufacturer's website. If you've done all this, you'll need to wait for me to get back so we can look at this in more depth. In the meantime, have you tried the UPnP method? This may help you get a HighID, so please confirm you've tried all the steps in the first post (and in this thread as a whole) and then we'll know where we stand.

ginger
Registered user
Registered user
Posts: 794
Joined: Thu Sep 13, 2007 11:09 am
Been thanked: 1 time

Post by ginger » Sun Sep 30, 2007 8:57 am

HOORAY!!! :banana2

HI ID at last!

I was beginning to think it´d never happen, I´d tried everything; port forwarding, turning off firewalls, creating a static IP, I even removed Norton after Tex´s advice, but nothing worked.
My router ia a XAVI 7868r which doesn´t show in the lists of links here, there is a support forum, but it didn't help.
It does let me open a range of ports though, so today I opened 4661-4662 TCP and 4672 UDP and YIPPEE!
I´d tried using default ports and other random combinations before, but nothing ever happened.

My mule and I are very happy, but is there any reason why I shouldn´t open a range of ports?

Thanks to everybody who´s posted in various threads (sticky, please for those who are still blindfolded :) )

"If at first you don´t succeed, try, try again" Good luck!


(Edit) Thinking about it, what seems to have worked is deleting Norton and then completely reconfiguring, so, all credit to Tex. Cheers :thumbs

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Re: Firewalled on KAD - need help to change it to open

Post by Tex2002ans » Sun Sep 30, 2007 6:57 pm

ed2kuser wrote:- default ports & a random range of ports (including corresponding router adjustments & re-starting emule with any port changes)
- uPNP abled and disabled
- leaving emule running overnight thinking that it (Open connection) may be a function of time, i.e. longer you wait the more chance of getting an Open connection
ed2kuser, try to turn on Options - Security - Enable Protocol Obfuscation. Also, under Options - Connection - Client Port - TCP (and UDP), type in some ports which are not the default ports (which are 4662 and 4672). Preferably you want to type in higher numbers. (I prefer numbers 6000+). :) Now open up those specific ports in your router, it seems like you already know how to open ports. :)

That might help with your problem (especially try the Protocol Obfuscation).
ginger wrote:HOORAY!!! :banana2

HI ID at last!

I was beginning to think it´d never happen, I´d tried everything; port forwarding, turning off firewalls, creating a static IP, I even removed Norton after Tex´s advice, but nothing worked.
And that is good that you got a high ID ginger, now what do you have as your anti-virus program? I would recommend NOD 32 (which you can find on sharethefiles). It uses up a lot less system resources, scans for viruses faster, updates by itself, and crushes Norton. :P
ginger wrote:My mule and I are very happy, but is there any reason why I shouldn´t open a range of ports?
Yep, you should minimize the amount of ports you open up, because hackers scan networks to find open computers, and if you open up too many ports they could probably use one to get into your computer and install malicious software.

ginger wrote:(Edit) Thinking about it, what seems to have worked is deleting Norton and then completely reconfiguring, so, all credit to Tex. Cheers :thumbs
Yeah, that would also help, Norton is very stubborn (at least in my experience). You're welcome ginger.

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Mon Oct 01, 2007 2:01 am

ed2kuser wrote:Forgot to say that I have tried Protocol Obfuscation too - both on/off, still no different. Likewise with higher number ports - I have tried them too but still I am getting firewalled in Kad. Definitely not sure what is going on here. Any idea?

Thank you for your help (tex2002ans).
Perhaps start from scratch all over again. Get rid of all the rules you created in your router, get rid of all the rules in your firewall (if you created them), set everything in Emule back to default. And then do everything over again. :) That might fix it. hahaha

dookie311
Registered user
Registered user
Posts: 12
Joined: Wed Sep 05, 2007 4:09 am

Post by dookie311 » Mon Oct 01, 2007 3:46 am

ok i can't get a high id. i have two computers sharing broadband internet through a belkin f5d7230-4 router both running win xp 2nd edition the host pc has mcafee virus scan, the second computer has zone alarm firewall and spy sweeper here is a picture of my router settings, what am i doing wrong??? i will love and cherish whomever can help me :pir8

Image[/img]

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Mon Oct 01, 2007 4:14 am

dookie311 wrote:ok i can't get a high id. i have two computers sharing broadband internet through a belkin f5d7230-4 router both running win xp 2nd edition the host pc has mcafee virus scan, the second computer has zone alarm firewall and spy sweeper here is a picture of my router settings, what am i doing wrong??? i will love and cherish whomever can help me :pir8
Make sure you do this with the computer that is running Emule. Open up your Start Menu - Run. Now type cmd into the box, and press ok.

This should open up the command prompt. Now type "ipconfig /all" (without the quotes). Now look for something that says "IP Address." That should give you your IP address for THAT computer. (It should be something along the lines of 192.168.2.xxx (those three xxx numbers are the important ones).

Now go onto your router, exactly where you took that picture. And instead of where you have 192.168.2.2, put in the three xxx numbers you got from ipconfig. That should fix everything. Do the same thing with the second computer you have Emule on.

(And I see you use Internet Explorer... I would recommend Firefox. And also I would recommend uninstalling AOL :P).

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Tue Oct 02, 2007 12:51 pm

OK this is the list of people who are still needing help, please say if you are now fine:

seggers
ed2kuser
dookie311
orion1983

General Help:

emule is good in that setting it up properly does expose you to the inner workings of your network setup. Emule was designed to be efficient with data transfer and so uses the UDP protocol which is much more efficient than TCP. This is the reason behind the punishment of being branded with a LowID. Everyone's computer is already set up to use TCP, but UDP isn't. This is why we need to manually open a port dedicated to UDP transfer. So, there's 2 sources of LowIDs -- your router isn't configured to allow UDP communication from the outside world to be able to even see your computer, and then once it is configured, then its possible the security programs you have installed are blocking them as well. I've taken the time to explain all this so as to help you as much as possible make sense of what 'settings' you encounter in your various security apps. You should be able to follow the signal path from the moment it enters your house via cable or telephone line thru whatever devices you have and whatever software apps you have, and do this correctly! Ok, to more specific help:

Seggers: please try to get a highID with emule first, and then return to using Shareaza. I don't know crap about shareaza.

ed2kuser:
i'm not such an expert on KAD firewalling but i'll try to help regardless... i used to have this problem a bit, but it was always connected to problems with server LowIDs -- although i do remember a small spell where i always got server green, but KAD yellow (that's what you're seeing right?) ... pls confirm that you are still able to get a consistent HighID with the few remaining servers still standing (its at 30 in total -- i remember the days we were getting 130-140!)

Dookie: see how you go with Tex2002's help and report back please.

orion1983 - we gotta set up your router (or at least check it) -- your modem is rather hard to find documentation on, please check out the Support page on the official emule website and have a look at the instructions for the other modems listed there. This is probably the best bet if you don't have access to an english copy of the manual for the modem. It's a German brand i take it.

Special thanks to Tex2002ans for helping out with support but thanks to all who posted, the body of lore grows larger.

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Tue Oct 02, 2007 3:49 pm

orion1983 wrote:Please Help!!!
4) what you have already done to try to achieve a HighID.
Port forwarding, Static IP, Turned off Windows firewall, ive tried higher port numbers and also default ones.

I will admit that I am not sure if the computer is properly port forwarded. My router was setup by someone else who also uses emule (and speaks german), and was told that I was good to go on that level. I have checked out sites like portforward.com and some of the other locations suggested in this and other threads, but my router is not listed and no advise could be given.
Ok, so I searched the internet (there is barely anything on there about this router). I also looked on their website and found the router (even though I can't speak German hahahaha), and I couldn't find anything along the lines of documentation (I know in German it would be very close, just spelled differently). But through a tiny bit more searching I found this.
this is an easy one. The first thing is to free up your computers then open the ports for these. Its different to other routers but as i have the same router and have done this then follow on

First find out both computers IP & name.
Go into your router config (http://192.168.2.1)

and click on Netzwerk
then pick Nat & Portregeln
Then PC's Übernehmen & Freigeben
where the IP is from the first computer add the name and click on the button Übern. after this.
You end up back at the previous menu.
now click on the Port-Weiterleitung button
Then Neue Regel defenieren
The pulldown menu you dont need so leave blank.
Where is say Bezeichnung add any title you want such as "HALO1" (HALO" for the second computer)
Click the Aktiv box to activate this
Gültig fürpulldown menu pick out the first computer and
TCP or UDP add the port to free up
Dont forget to click on the Speichern<< button on the bottom to save this to the router.
So, let me see if I can help you out.

First, go Start Menu - Run. Type "cmd.exe" (without quotes) into the box. Now type "ipconfig /all" (without quotes) into the command prompt. This will pop up all this information, and you want to get the numbers where it says IP Address:

Now, open up IE or Firefox or whatever browser you use, and type 192.168.2.1 and go to it. I will assume you know how to get into the router (if it has a password or whatever).

So Now you should just be able to follow the instructions I found, except you type in your information (the TCP and UDP ports you use for Emule). If you need any more help, you could post a picture when you get to where this guy explained. Even though your router is all in German we still might be able to help. :D
soporific wrote:Special thanks to Tex2002ans for helping out with support but thanks to all who posted, the body of lore grows larger.
Your welcome soporific, but THANK YOU, for making this thread... which I can then take over and help people in. :twisted: hahaha

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Tue Oct 02, 2007 7:53 pm

http://www.portforward.com/english/rout ... /eMule.htm

Portforward.com doesn't have your exact router, but I think the router that is a level below it should be exactly the same. :)

So the same thing as the other people have been asked to do, Start Menu - Run - "cmd.exe" and then type "ipconfig /all" on the command prompt. Get your IP Address. :D It seems like you know how to set up your Emule so I won't tell you that. If you need more help just ask.

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Re: banging my head against the wall!

Post by Tex2002ans » Fri Oct 05, 2007 10:54 pm

Nanook wrote:Cheers Tex disaster avoided, all is well on the ID front, im now High again.

keep up the good work.
Good good. And I will keep up the good work, thanks.
UnchosenFragmnts wrote:Anyways I just ran a speed test and I download at 4437 kb/s and upload at only 293 kb/s, I am going through a linksys router. Model number WRT54GS.
Was that speedtest run while your computer was the only one taking up the internet?

Also, all of that other stuff connected to the network might just mean you do not want to suck up all your internet with Emule. I will give you two different settings, one to have on if you want Emule sucking up most of your internet, or another setting which will allow you to play Xbox 360 and surf on other computers at the same time.

Although I am not too sure how much bandwidth a normal Xbox 360 game takes up, I will assume 10 KBps (if someone knows better please inform me).

With Emule using up most of your internet, set your uploading to: 23 KBps (29*.8). If your internet starts going slow then you could lower it to 22 KBps.

With Emule using up some of the internet, and allowing you to play your Xbox 360 online and/or surf on the other computer with no slowdown, set your uploading to: 13 KBps (this is giving you 10 KBps extra bandwidth for games/surfing the internet on the other computer)
UnchosenFragmnts wrote:I am running Windows Vista and the firewalls I have are Windows Firewall which is on and Norton which I beleive was a trial and has run out.
:P Well we all know how much I love Norton hahaha. If you want you could switch to NOD32.
UnchosenFragmnts wrote:I have tried and got a static ip. I have forwarded the ports through my router correctly. I have opened up the ports in Windows Firewall and I also have opened the ports and allowed the connection in Norton Internet Security. I used the port forwarding tutorials so I am fairly sure that all of that was done correctly. I also set to use uPnP to setup ports.
#1 IMPORTANT: Try to go into your router and manually add the ports, instead of trying to let uPnP solve it for you. Here is the link to portforward.com for your router (I have the same one) :D

http://www.portforward.com/english/rout ... /eMule.htm

#2: Did you try to use other ports besides the default ones?

#3: Also, if you already did all that stuff, then try to do another thing that I mentioned. Get rid of all the port forwarding rules you set (in Windows Firewall, Norton Internet Security, the router), reset your computer, and then redo them all over again. That sometimes fixes the problem for some weird reason. (Damn you Norton and Windows) :D
UnchosenFragmnts wrote:Kad is firewalled no matter what I try. And when I try to test ports the tcp port always fails. I have no idea what to do now except to just give up. HELP ME PLEASE!
Yeah so it is failing because something is blocking the ports (but my first gut instinct is... Norton hahaha).

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Wed Nov 14, 2007 1:55 pm

sorry, first type in CMD in the RUN window (and hit return), and then you can use IPCONFIG

baroni061241
Registered user
Registered user
Posts: 23
Joined: Mon Aug 20, 2007 7:33 am
Has thanked: 1 time

LOW ID

Post by baroni061241 » Tue Nov 20, 2007 3:04 pm

I am running eMule ver 48a on win/xp sp2 + all fixes, Norton internet security 2007, i have a Thompson cable modem NO router.

until a few days ago i had no problems of LowId, since than there is no way to get a highid, even though is i use the Test ports function a get a positive
resoult.

I checked everything i could think of, and still i get lowid.

Any ideas?

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Re: LOW ID

Post by soporific » Tue Nov 20, 2007 5:15 pm

baroni061241@yahoo.com wrote:I am running eMule ver 48a on win/xp sp2 + all fixes, Norton internet security 2007, i have a Thompson cable modem NO router.

until a few days ago i had no problems of LowId, since than there is no way to get a highid, even though is i use the Test ports function a get a positive
resoult.

I checked everything i could think of, and still i get lowid.

Any ideas?
so, when you use the Test Ports function in emule options, you get a pass ?? What servers are you trying to connect to? IF you get a pass with the tests, the problem isn't from your end, the problem is you can't connect to anyone good.

Also, if you use an ipfilter, try deleting it and see if it works then ... if not, just download a new updated ipfilter.

baroni061241
Registered user
Registered user
Posts: 23
Joined: Mon Aug 20, 2007 7:33 am
Has thanked: 1 time

Post by baroni061241 » Wed Nov 21, 2007 1:11 pm

1) which version of emule you are using, especially if it is a mod version.
eMule 48a (NO MOD)

2) your type of internet connection, and model & type of modem. It is imperative you know if you are connected to the internet via a router, or via a modem (whether its a broadband modem, or dial-up). If you don't know this information, it is going to be very hard to help you.
CABLE CONNECTION , THOMSON CABLE MODEM, NO ROUTER

3) your operating system, and a list of all 'security' applications - eg firewalls or 'total internet security' type apps. You generally don't need to list malware programs like "Spybot - Search & Destroy" or anti-virus programs but if in doubt list them all.
WIN XP SP2 + ALL THE HOTFIXES, NORTON INTERNET SECURITY 2007
4) what you have already done to try to achieve a HighID.
TRYED BOTH WITH AND WITHOUT FIREWALL.
TRYED ALL AVAILABLE SERVERS

5) most important: please confirm you have visited the Tutorial post (see above) and try to describe where you got up to, or how the tutorial failed to help you. This way we can improve the tutorial and maybe stop the need for threads like these.
THE TUTORIAL IS EXCELENT BUT DID NOT SOLVE MY PROBLEM

6) anything else you consider relevant.
1. MY CONFIGURATION WAS RUNNING AT HIGHID FOR THE PAST YEAR.
2. MY PORTS ARE REPORTED AS OPEN BY THE TEST IN THE "OPTIONS" MENU
3. AS I MENTIONED ABOVE DISABLING THE FIREWALL DOES NOT SOLVE THE PROBLEM

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Fri Nov 23, 2007 12:10 pm

jordan.holst wrote: 6) anything else you consider relevant.
--- this shouldn't be this difficult.
Yep, getting a HighID shouldn't be a pain, but it does alert us to the fact that something is wrong, and it needs to be fixed.

Things you can confirm for me:

* you have used the 'Test Ports' function of emule and it returns a negative result
* you have successfully setup an emule connection before - if not, are you confident you understand what each of the port forwarding settings mean and there is no way you could have got it wrong?

Things you can do to help me help you:

* provide some screenshots of your settings, if you don't know how to do screenshots, now's the time to learn. It's dead easy. I use SnagIt but there's heaps you can go with, google for 'Print screen' programs
- i want a screenshot of your IPCONFIG results, and your port forwarding settings.

Also, have you turned on UPnP ??

See how you go with that.

wudangpropd
Registered user
Registered user
Posts: 19
Joined: Thu Jan 11, 2007 9:57 am

Help

Post by wudangpropd » Fri Dec 07, 2007 2:45 pm

* upstream of your internect connection, your ISP (or some other nasty, CIA-like organization) is blocking the UDP protocol altogether. Possibility of this: 0.0000001% ... if you live in the US, possibility of this: 0.0001%
Could that have happened to me? I live in the US, had my ports forwarded, static ip, sp2 evipatch, sp2 firewall stopped, High ID! And one morning i rebooted the computer and was in low id!
Help please :cry:

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Re: Help

Post by soporific » Fri Dec 07, 2007 5:07 pm

wudangpropd wrote:
* upstream of your internect connection, your ISP (or some other nasty, CIA-like organization) is blocking the UDP protocol altogether. Possibility of this: 0.0000001% ... if you live in the US, possibility of this: 0.0001%
Could that have happened to me? I live in the US, had my ports forwarded, static ip, sp2 evipatch, sp2 firewall stopped, High ID! And one morning i rebooted the computer and was in low id!
Help please :cry:
OK, the very first thing you should do is check that the settings are all still current. Windows XP can be annoying in that sometimes a crash or some serious error wipes out some hardware setting and this changes the 'id' that the network address locater sees and thus thinks your computer is different and gives it a different address. You say you've set a static IP but check anyway.

the Ipconfig method to check
1. START -> RUN, and type in CMD and press return.
2. type IPCONFIG and press return.
3. check the result for IP Address -- it should be the same as the one you setup in port forwarding.

this is really the only setting that can change by itself just by a simple reboot. You may have to try to provide more info if the above doesn't work.

wudangpropd
Registered user
Registered user
Posts: 19
Joined: Thu Jan 11, 2007 9:57 am

thanks for the answer!

Post by wudangpropd » Fri Dec 07, 2007 7:42 pm

it's the same ip adress as the one forwarded. what kind of info do you need? thanks

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Re: thanks for the answer!

Post by soporific » Sat Dec 08, 2007 5:39 am

wudangpropd wrote:it's the same ip adress as the one forwarded. what kind of info do you need? thanks
Please answer all the questions in the first post. Also, screenshots of your settings is also useful.

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Sat Dec 22, 2007 8:24 pm

JoeNut wrote:Port forwarding (which worked, and then next time i turned comp on it was back to low ID)
6) anything else you consider relevant.
Its been HighID once, and then once i turned my computer off and on again its back to lowId ;(
Just sounds like you do not have a static IP (so when you turned your computer back on, your router gave you a slightly different IP). This tells you how to set yourself as a static IP:

http://www.portforward.com/networking/static-xp.htm

Now since you already have port forwarded, I think you know what you are doing, so just go into your router and find out which IP address you opened the ports for, and set that as your static IP. :D

If you need any more help just ask.

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Sun Dec 23, 2007 2:10 am

Try it, who knows it might work.

And be sure to do cmd - ipconfig /all again in order to see that your IP has actually changed to the static IP you actually set.

darklittlecorner
Banned
Posts: 40
Joined: Mon May 14, 2007 10:29 am
Been thanked: 1 time

Post by darklittlecorner » Sat Jan 05, 2008 3:58 am

There might be someone in the same boat as me, so I thought that I would post this.

When I first started using eMule, I had noticed that I had low ID, but I paid it no mind. After all I was still able to download movies, right? As I became a more serious user, I wanted to rid myself of this low ID and get High, ID that is.

So I followed the directions in the various guides but to no avail. My firewall and ports were already set. So I started playing around with my modem settings and to make a long story short this is what I did.

I have a Westell B90 series modem. First make sure that you have the latest drivers.

You type launchmodem in the address bar.

Choose Home Network

Click on IP Passthrough

Click enable

The modem will restart.

Enter your username and password.

When your internet connection connects close that browser window.

Then start eMule and you should have high ID.

I hope that this helps you if you have tried every other option, or if you are using a Westell modem.

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Sat Jan 26, 2008 8:02 am

OK, here's a new bit of wisdom i'm adding to the list in the first post:

* become buddies with your router or router/modem. If you're not regularly logging into it and checking out how things are, you aren't going to have much luck fixing problems when emule suddenly doesn't work. So, if you can't log in to your router, you need to tell us this because that is what we will focus on to help you. Logging into your router is simple. Use the method in point 8 (of the first post) to do this. You will need to know the username and password of your router. 99% of the time you will be able to use 'admin' for the username and 'admin' for the password if you haven't changed it from the default. Sometimes the password is 'password' so try that if 'admin' doesn't work. This is a security risk if you haven't changed it so i recommend doing this ASAP. The most common things to do once you've logged in are: * check the line connection is in SYNC (you can see your signal-to-noise connection ratio); * check that you are connected to the net (you can see your IP address); * check the current list of forwarded ports; * do a self-test on the router to see if it reports any faults; * and other useful things as well. So, please remember to tell us if you can't log in to your router.

demonwizz
Registered user
Registered user
Posts: 3202
Joined: Wed Nov 14, 2007 7:35 pm
Been thanked: 7 times

Post by demonwizz » Sat Feb 09, 2008 5:02 pm

rogue727 wrote:Actiontec DSL modem GT701R

4) confirm if you can or cannot log in to your router (if you have one). If you can't log in (or haven't ever done so), this is why you haven't got a HighID. Concentrate on this step if this is the case. If you can't log in, don't worry about anything else, fix this first. We can help you with this, just inform us you can't log in.
i can log into my router
http://www.portforward.com/english/rout ... efault.htm Actiontec DSL modem GT701R default router guides
http://www.portforward.com/english/rout ... /eMule.htm Actiontec DSL modem GT701R emule guides

You haven't mention about this modem earlier. And McAfee when was uninstalled didn't activate your xp firewall so you cant open ports.

http://www.udel.edu/security/sectopicsw ... ewall.html How to activate windows xp firewall after uninstalling McAfee

Hope that this will help you with firewall.

Tex2002ans
Registered user
Registered user
Posts: 283
Joined: Fri Nov 10, 2006 6:33 am

Post by Tex2002ans » Thu Feb 14, 2008 7:50 pm

bombagirl wrote:I think the problem is coming from my isp connnection as somehow downloads vary
I doubt that. It is either one, or a mix of these:

1: You haven't set your Emule up optimally.
2: You haven't set up your router properly.
3: I see in one of your earlier posts you downloaded "we blocker," and from another post I read it seems like they are having problems. Try uninstalling we blocker.

Steps I would do:

Uninstall we blocker. Get rid of all the rules in the firewall and router that you set up before and start from scratch. Read the rest of this topic to find out how to get your IP (command prompt, ipconfig, blah blah blah). If you need any more detailed help, you know where to ask. But my recommendation is start from scratch, who knows, it might just work. :P
Mystical78 wrote:Ok does anyone have any knowledge of using this with windows Vista?
No clue how to do stuff on the virus that is Windows Vista. Sorry. :P
Mystical78 wrote:Ok maybe I am meant to have low ID forever now because them pages didnt help me-I went through the steps and nothing-Also my list of servers to choose from I get maybe 10 not before i had a full pages
http://peerates.net/peerates/index.html

That has one of the safe server lists. I just downloaded it and it has 30 servers on the list. If you had "pages and pages" of servers before, they were mostly fake.
rogue727 wrote:dsl, im on a laptop using a linksys wrt54gv4 wireless router and Actiontec DSL modem GT701R. my connection is modem -> wireless router -> laptop
Ok, I think you have to set up the rules through your modem and your router exactly the same I THINK, I'm not too sure how that works with the modem as a router + a wireless router (never had one myself so I don't know the details). :P

So here is the link for your modem:

http://www.portforward.com/english/rout ... /eMule.htm

and here is a link for your router:

http://www.portforward.com/english/rout ... /eMule.htm
rogue727 wrote:Port Forward, Static Ip, tried low ports and high ports did not get a chance to use the default ones, oops... turned firewall on and off, enabled upnp under administrative tools
The more I read the more I think it is a problem that you aren't port forwarding correctly, and I am not too sure how to do that (as I explained before, basically going through two routers). :P

I think on your modem, you would need to put in the IP address it is giving to your wireless router (not too sure how to get that exactly), and on your router you would have to stick in the IP address it is giving your computer (which is the easy stuff we have been doing here for a long time).

I just came up with a plan, just plug your laptop straight into the modem, and see if you can get Emule working fine through that. If you can, then you know that when you add in the router that that is the real problem which we can then delve further into.
rogue727 wrote:7) anything else you consider relevant.
Modem LAN IP - 192.168.0.1
Modem IP - 75.174.174.14
Router IP - 192.168.1.1
Laptop IP - 192.168.1.140
This will be relevant later, when we get down to the nitty gritty. :P
rogue727 wrote:under my security center it says my windows firewall is on and running and ive open ports thro that firewall also, i read thro that link but in emule that one option is still grayed out, other than that i will follow the other links to open my modem
Get rid of your windows firewall and any of the fancy stuff you did before. I would say here also, start from scratch. Run Emule, allow it through Windows Firewall, then set up the rules through your modem to try to get High ID. We need to just focus on one problem at a time instead of taking them all on at once.

PS. Yes... yes I did stick that many smilies in a help post. :D

soporific
Software Moderator
Software Moderator
Posts: 180
Joined: Mon Jul 26, 2004 10:55 am
Location: on a soapbox somewhere in the world
Has thanked: 1 time
Been thanked: 6 times

Post by soporific » Sat Feb 16, 2008 8:10 am

just checking in, does anyone still need help? Mystical78, how does your ID go, High or Low?

Cheers to all replies for those who needed help, especially the wordy ones with lots of info ... it warms the cockles of my heart to see such a helpful spirit but we should expect that by now, this is STF 8-)

meepers369

Post by meepers369 » Sun Mar 02, 2008 9:14 pm

I've continuously failed the test port option, even with default ports, changing the ports, using upnp. I've tried turning off my windows firewall (I have vista), then even tried to add ports manually through the vista firewall. I've tried resetting my firewall options and resetting the "virtual ports" section on the router settings. Still have LowID, sadly. Any ideas?

1) which version of emule you are using, especially if it is a mod version.
v.0.48a

2) your type of internet connection, and model & type of modem. It is imperative you know if you are connected to the internet via a router, or via a modem.
wireless connection with Belkin F5D8231-4 router

3) your operating system, and a list of all 'security' applications - eg firewalls or 'total internet security' type apps.
windows vista, AVG

4) confirm if you can or cannot log in to your router (if you have one). If you can't log in (or haven't ever done so), this is why you haven't got a HighID. Concentrate on this step if this is the case. If you can't log in, don't worry about anything else, fix this first. We can help you with this, just inform us you can't log in.
yes

5) what you have already done to try to achieve a HighID.
redownload emule, static ip, port forwarding, windows firewall on and off, default ports new ports, upnp enabled

Post Reply

Return to “Technical Support & Discussion”