Page 1 of 1

aMule non starter on MacOS Mojave

Posted: Sun Nov 04, 2018 10:06 pm
by soundog
I have been quite happily using aMule for many years now, updated the OS to MacOS Mojave a few weeks ago, and today I received a pop up saying that

'aMule is not optimised for this Mac'

now when I click on the docked icon it bounces for a few and then just stops. I was wondering if anyone has any insight, or ideas how to remedy the situation? cheers in advance

Re: aMule non starter on MacOS Mojave

Posted: Mon Nov 05, 2018 2:40 pm
by raffe
The warning only means that aMule is running as a 32bit app, and Mac like 64bit (see here: https://www.computerworld.com/article/3 ... ssage.html )

But, about it not starting, according to https://www.techradar.com/how-to/macos- ... o-fix-them "If your software is very outdated, it may no longer be compatible with macOS Mojave". So, for free choices, maybe you could ask for help at http://forum.amule.org/ or try an other app (like http://mldonkey.sourceforge.net/phpBB2/ ... m.php?f=15 ) or try to start aMule or eMule (https://www.emule-project.net ) on a virtual machine (like https://www.virtualbox.org/ ) with Windows (maybe one from here viewforum.php?f=20 ).

I don't use Mac, so maybe you get better answers from somebody else :-)

Re: aMule non starter on MacOS Mojave

Posted: Mon Nov 05, 2018 10:42 pm
by soundog
thanks very much for the assist... I'm looking into alternatives at the moment.. used Time machine to go back 3 days to when I last used aMule (and it booted successfully) and bizarrely it opened first time. was informed that I might need to delete aMules cache.. but that answer was left somewhat ambiguous so I'm looking into that to, just if it ever happens again