Erroneous Download Error

Your computer feeling a lot slower lately? That new program you installed not working? Can't convert a specific file? Looking to buy a new hard drive or dvd writer? Would like some recommendations? Firewalls, latest threats and general P2P security issues are here also.
Post Reply
LordDan
Donator
Donator
Posts: 33
Joined: Tue Feb 12, 2008 7:45 am
Location: California, USA
Has thanked: 447 times
Been thanked: 1 time

Erroneous Download Error

Post by LordDan » Fri Dec 22, 2017 8:42 pm

Good morning everyone,

I'm usually pretty good about troubleshooting computer related problems, but this one has me stumped and I've been unable to find anything on the net with anything remotely close to a solution - so here I am reaching out to the experts! :)

About a week ago, emule (50a - no mods), crashed from an extended power outage while I was away from home and the UPS simply went dead the computer didn't shut down properly. When I restarted it, the computer came up perfectly fine, and emule did as well, so I got it going and sharing files again. But now it won't complete a download - it comes up after reaching 100% and hashing the file that an Erroneous status now takes over in the STATUS column of the Transfer tab, the PROGRESS column goes from green to a hashmark yellow showing 00.0% and in the server log, it reports "Creating File Completion Thread Failed".

There's plenty of hard drive space, so I know it's not that. I'm sharing over 8,000 files, but I've been sharing large numbers of files for years and not had a problem prior to a week ago with the crash.

I'd hate to have to reinstall everything because I have it perfect right now, but if that's my only solution, then I'll do that. But if anyone has any suggestions on what I can try, I am open to your thoughts...

Thank you for your help and I wish you happy holidays! Dan

hrmwrm
Registered user
Registered user
Posts: 69
Joined: Sun Dec 26, 2010 8:12 pm
Location: Alberta, Canada
Has thanked: 1 time

Re: Erroneous Download Error

Post by hrmwrm » Sat Dec 23, 2017 4:01 am

maybe make sure your permissions haven't changed. something may have corrupted in the config. it may not be able to save to your finished folder.
usually the yellow hash mark clears with a right click, resume.

this is all downloads, or just 1?
if just 1, .part might be corrupt. delete the download and start again, making sure first to note the part # applicable to the file and physically delete it from the temp if there after canceling.

LordDan
Donator
Donator
Posts: 33
Joined: Tue Feb 12, 2008 7:45 am
Location: California, USA
Has thanked: 447 times
Been thanked: 1 time

Re: Erroneous Download Error

Post by LordDan » Sat Dec 23, 2017 4:41 am

All downloads since the outage. Even new files that I start to download since, they will go all the way through downloading, show the progress bar all the way to 100%, but then it displays the yellow hash warning on the Progress column and the error shows on the Status column and then the note in the Server log screen. And no option to right-click resume on these files. Interestingly, the files ARE complete in the temporary folder, so I was able to at least still keep the files and just copy them over to another folder, rename them to what it should be, and then move it over to my shared directories. I checked the files (mostly video) and they all play or extract just fine - so it seems like it's just the process that copies the temporary file to the download folder once it's complete, which that folder is fine.

I already checked permissions, read-only status flags, reset the computer a handful of times, and even did a system restore to a date prior to the outage - nothing has worked. Running Win7 Enterprise 64 - decent specs (I'm a tech geek).

I've been using emule for over a decade and this was the first time I've had this kind of error where I couldn't figure it out, so it's probably as you said, something got corrupted with the incorrect shutdown process. Oh well, "stuff" happens. :(

I will probably just re-install - it doesn't take that long to get my settings back to where they are now (just took screenshots of each setting page). I'll probably do that in the morning tomorrow since I'll have time to spend an hour or so just to make sure I'm back online and sharing. :)

hrmwrm
Registered user
Registered user
Posts: 69
Joined: Sun Dec 26, 2010 8:12 pm
Location: Alberta, Canada
Has thanked: 1 time

Re: Erroneous Download Error

Post by hrmwrm » Sat Dec 23, 2017 7:37 am

have you in options reset the folders to be sure they are right? other than that, i was just thinking possibilities. as stated, it's fine til it changes from part to complete.

LordDan
Donator
Donator
Posts: 33
Joined: Tue Feb 12, 2008 7:45 am
Location: California, USA
Has thanked: 447 times
Been thanked: 1 time

Re: Erroneous Download Error

Post by LordDan » Sat Dec 23, 2017 8:38 am

Yes, all that was correct. I had time tonight, so I just reinstalled and am back online sharing. I did a test download and all is good.

No idea what caused the corrupt setup, but I did a clean reinstall of emule and reconfigured the settings to how I had them in about 35 minutes, so not too bad. All is well again in STF land. :)

hrmwrm
Registered user
Registered user
Posts: 69
Joined: Sun Dec 26, 2010 8:12 pm
Location: Alberta, Canada
Has thanked: 1 time

Re: Erroneous Download Error

Post by hrmwrm » Sat Dec 23, 2017 9:08 am

just thought of a few things i might look at. i run with mule on a seperate drive and have never had trouble.
look at options/extended scroll down to safe met/dat file writing and be sure it is set to always. it'll help stop corruption from sudden/unintended shut downs.

LordDan
Donator
Donator
Posts: 33
Joined: Tue Feb 12, 2008 7:45 am
Location: California, USA
Has thanked: 447 times
Been thanked: 1 time

Re: Erroneous Download Error

Post by LordDan » Sat Dec 23, 2017 11:26 am

Me too... :) Install is on C: Temp folder and initial save folder are both on D: My entire shared collection is on my 32Tb NAS (8,220 files at last count when I restarted emule after the re-install a few hours ago). Good upload/download speeds here, so I flow through the people waiting in about 2 hours based on my estimates to upload single chunks (9.28 megs). I give friend slots whenever asked. :)

Anyway, all is going well - been running for a couple hours now and no hiccups, so I'm going to bed (it's 2:30am here in California, USA). Thanks for the ideas - we were both on the same page. :)

Good night.

Post Reply

Return to “Technical Support & Discussion”